Dremio is going through a maintenance update for one of the service in our US cluster

Incident Report for Dremio Cloud

Resolved

Service update was delivered.
Posted Feb 18, 2026 - 17:55 UTC

Identified

Dremio is going through a maintenance update for one of the service in our US cluster. This may impact some queries. The system should be fully functional within 10 minutes
Posted Feb 18, 2026 - 17:44 UTC
This incident affected: Dremio Cloud - US (Site Availability).