All upgrades are finished. Both regions are fully operational. Thank you for your patience.
Posted May 09, 2026 - 22:18 UTC
Update
Upgrades are now underway for the US. Dremio Cloud US may be temporarily unavailable.
Posted May 09, 2026 - 18:52 UTC
Update
Upgrades in Europe are complete and the region is fully operational. Upgrades for the US region will begin shortly.
Posted May 09, 2026 - 18:43 UTC
In progress
Upgrades are now underway for Europe. Dremio Cloud Europe may be temporarily unavailable.
Posted May 09, 2026 - 16:18 UTC
Update
Upgrades for the Europe region will begin shortly.
Posted May 09, 2026 - 13:28 UTC
Scheduled
Upgrades will be performed on Dremio Cloud Europe and Dremio Cloud US. Dremio Cloud may be unavailable intermittently during this time. We will provide updates as necessary.
Posted May 09, 2026 - 05:48 UTC
This scheduled maintenance affected: Dremio Cloud - US (Site Availability) and Dremio Cloud - Europe (Site Availability).