This incident has been resolved. Earlier today, an infrastructure issue on Dremio Cloud (US) caused query timeouts and failures for some users. Our team identified the cause, restored service for all affected users, and confirmed that the environment is operating normally. We appreciate your patience.
Posted Apr 09, 2026 - 00:10 UTC
Identified
Our team has identified the cause of query failures on Dremio Cloud (US) and has applied an initial fix. Query execution has been restored for the majority of users. Some users may continue to experience intermittent query timeouts as our team works to fully resolve the remaining impact. We will continue to provide updates.
Posted Apr 08, 2026 - 23:18 UTC
Investigating
We are investigating an issue affecting query execution on Dremio Cloud (US). Some users may experience query timeouts or failures when running queries. Our team is actively working to identify the cause and restore normal operation. We will provide an update as more information becomes available.
Posted Apr 08, 2026 - 22:38 UTC
This incident affected: Dremio Cloud - US (Site Availability).